关于yarn禁止在此系统上运行脚本

Entropy Lv4

nodejs中使用yarn安装依赖失败

错误原因

windows默认执行策略禁止脚本

解决方法

  1. 在电脑的开始菜单中,搜索PowerShell,并以管理员身份运行
  2. 在窗口输入命令get-ExecutionPolicy查看权限,如果返回值是Restricted,则表示当前是禁用状态
  3. 在窗口输入命令set-ExecutionPolicy设置权限
  4. ExecutionPolicy参数提供值RemoteSigned,后面输入A之后再回车(默认为否),开启所有脚本权限
  5. 重新测试yarn命令
  • 标题: 关于yarn禁止在此系统上运行脚本
  • 作者: Entropy
  • 创建于 : 2022-09-05 21:36:27
  • 更新于 : 2023-04-01 07:55:52
  • 链接: https://www.entropy-tree.top/2022/09/05/yarn-problem/
  • 版权声明: 本文章采用 CC BY-NC-SA 4.0 进行许可。
评论
此页目录
关于yarn禁止在此系统上运行脚本